Support portal issues
Incident Report for TriNet
Resolved
All Zendesk support portal issues appear to be resolved now. We're working hard to catch up on the tickets, sorry for the delays today!
Posted about 2 years ago. Aug 26, 2016 - 12:42 PDT
Monitoring
Zendesk, which powers our support portal, is having issues with it's services this morning. We will get back to you as quickly as we can once the services return.
Posted about 2 years ago. Aug 26, 2016 - 09:35 PDT