Help Desk Latency
Incident Report for TriNet
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 18, 2016 - 22:26 PDT
Monitoring
Our help center vendor is experiencing high latency. As a result, we are having a difficult time responding to your phone calls. We will continue to monitor their progress and will get back to you as fast as we can. In the meantime, please email us support@trinetcloud.com.
Posted over 1 year ago. Oct 18, 2016 - 10:03 PDT