Elevated API Errors
Incident Report for TriNet
Resolved
All issues should be resolved now, thank you. If you see any other issues please contact support@trinetcloud.com
Posted about 3 years ago. May 05, 2015 - 07:04 PDT
Identified
We've identified an issue with a server update and are resolving it now. Should be back in a few minutes.
Posted about 3 years ago. May 05, 2015 - 06:57 PDT