Expense Outage
Incident Report for TriNet
Resolved
AWS Services have been restored, we're back up!
Posted about 2 years ago. Nov 10, 2015 - 11:16 PST
Identified
We're currently experiencing high error rates in the US-West region for AWS. This is primarily effecting the Expense server. Moving to maintenance until it can be resolved.
Posted about 2 years ago. Nov 10, 2015 - 10:57 PST