Expense issue
Incident Report for TriNet
Resolved
Issue was related to the upstream data. It has been resolved, but we will continue to monitor it.
Posted 11 months ago. Sep 11, 2017 - 12:13 PDT
Investigating
An issue with Expense is in progress, we're investigating now.
Posted 11 months ago. Sep 11, 2017 - 11:32 PDT