Expense Outage
Incident Report for TriNet
Resolved
Issue resolved. All systems operational.
Posted Oct 22, 2019 - 11:46 PDT
Identified
Expense is experiencing an issue with its database. The team is addressing the issue now.
Posted Oct 22, 2019 - 10:33 PDT
This incident affected: Expense.